sexta-feira, 5 de fevereiro de 2016

Nova atualização do APT (Advanced Package Tool) 1.2.2 traz de volta o Build-Dep Command

Pra quem não conhece (duvido muito), o APT é um conjunto de ferramentas do debian que torna possível instalar, desinstalar, atualizar e etc os pacotes do sistema debian. Agora ele foi atualizado mais uma vez trazendo certas melhorias.



APT é uma sigla para Advanced Package Tool,  a maioria dos usuários de Linux já devem ter ouvido falar dele, mesmo que eles não usam Debian ou qualquer derivado do Debian. É um dos pacotes mais importantes em qualquer distribuição.

Depois de anos de trabalho em cima do APT, finalmente os desenvolvedores lançaram uma nova atualização para ele.

Mas enfim, o que há de novo no APT 1.2.2?


Vai ainda levar um longo tempo até que esta versão se torne padrão nas novas distros baseadas no debian, mas por enquanto ela se encontra disponível para os usuários do debian instável, esta versão já se encontra disponível nos repositórios, caso seja um usuário da versão instável do debian, basta fazer uma atualização.

Segundo a Changelog, o Pkg agora irá ser criado ao mesmo tempo que o Pkg:arch também é criado, o Build-Dep foi reimplementado com sucesso pelo resolvedor normal (se isso quer dizer algo, só traduzi o que tinha na fonte ^^), a versão opera agora corretamente a partir da fonte do campo binário, as gravações de buffer já não podem ser maior do que o buffer padrão, quaisquer erros de e / S fará com que o APT falhe, o carregamento de uma descrição longa do pacote é agora evitado, e muito mais.

Uma lista completa das modificações e atualizações podem ser encontradas no changelog oficial. Caso queira baixar a nova versão do APT, pode baixar A partir deste Link abaixo:



EmoticonEmoticon